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Introduction 
When you are documenting your workflows, in a sense, you are providing training material for another 
person to do the job. Here are some tips to get started: 

 Less is more: Simplify the process to the simplest approach and least number of steps possible. 
Simplify the presentation of the information so that the document contains only what is required 
and is presented as clearly as possible. Avoid irrelevant information, such as the history of a 
process, unless it contributes to the motivation of the learner (e.g. demonstrates why the process 
is important, negative consequences of not following it properly, etc.) 

 Think like a novice: If you are experienced in this process, try to think like you are new to it or 
ask someone less familiar with the process to test your documents. As an expert, you may skip 
steps or combine multiple steps in ways that a novice may find confusing.  

 Provide the big picture: Help the learner develop an overall concept of the process that they can 
fit the tasks or steps into. You may or may not be there when they are learning the process. One 
way to do this is with a process map. Below is a simple example of a process map for the workflow 
documentation process. 

 Include Background information: You will often be describing procedures, but it may be helpful 
to include some supporting information at the beginning or end of your documentation. Some 
examples might include: 

o Key roles/personnel 
o Acronym definitions 
o Computer system definitions 
o Frequently asked questions 

 Organize the Files: Set up a common folder for all the files related to a project. Consider adding 
subfolders for each asset type: 

o Audio 
o Documents 
o Images 
o Video 

 Use the template: Using the documentation template described in this document reduces the 
time and effort required to document the workflow. 

Process Overview 
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Task Analysis 
You can jump right in on a task you are currently performing or do a simple task analysis. To do a task 
analysis, start a document and write down the primary responsibilities of your job. Divide these job duties 
into tasks. This task may have multiple subtasks. Subtasks would ideally contain between 5 to 9 steps and 
be able to be completed within 30 minutes. If a task or subtask contains too many steps or takes too long 
to complete, try to break it down further into additional meaningful subtasks. 

 

Why 30 minutes:  

 Provides opportunities for practice 
 Fits attention span 
 Provides manageable blocks of 

material for ease of instruction and 
learning 

 Allows flexibility in situations where 
operating conditions require short 
periods of training 

 May be easily modified as 
specifications, processes, procedures, 
equipment, etc. are updated 

 Gives trainee sense of 
accomplishment 

 Allows for immediate and specific 
feedback 

 

 

 

 

 

 

 

 

 

From: USDA National Resources Conservation Service 
http://www.nrcs.usda.gov/Internet/FSE_DOCUMENTS/nrcs142p2_051333.pdf 
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Setting up Programs and Files 

Setting up SnagIt 

1. Open SnagIt by double clicking 
on the icon in the System Tray, 
located in the lower right 
corner of the screen. 

 

2. The SnagIt window will open. 

 

3. Select the + sign beside 
Presets. 

4. Select New preset… 
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5. The Edit Preset dialog box will 
open. Select Image. 

6. Use the following 
a. Selection: Region 
b. Effects: None 
c. Share: None 
d. Preview in Editor: On 
e. Copy to Clipboard: On 
f. Capture Cursor: On 
g. Time Delay: On 

3 Seconds 
h. CTRL+ALT+C  

(Choose a hotkey that 
doesn’t conflict) 

7. Select Save Preset. 

8. Rename the preset 
“Documentation” 
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9. Add a hotkey by clicking in the 
“Add a hotkey” box and press 
CTRL + ALT + C. 
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Setting up the Ribbon in Microsoft Word 
This will only need to be done once. If you have customized the ribbon yourself prior to this, please 
know that this process will eliminate your customizations. 

1. Right Click on the Ribbon and 
Select Customize Ribbon. 

2. Select the Import/Export 
button. 

3. Choose Import customization 
file. 

4. Browse for the file named 
“DocumentationTemplate.expo
rtedUI” 

 

5. Select Yes to replace the 
existing Ribbon customizations. 
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Setting up the Template in Microsoft Word 
Following this process will help keep the Quick Parts from “disappearing.”  

1. You should have a copy of the 
MS Word template named “Cal 
Poly Process Documentation 
Template.” 

 

2. Save the template in 
Documents > Custom Office 
Templates.  
 
Note: If the folder doesn’t 
exist, you can create it. 

 

3. Click on the File tab and 
choose Options. 

4. In Word 2013: Select Save and 
change the Default personal 
templates location to: 
C:\Users\username\Documents
\Custom Office Templates 
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5. In Word 2010: Select 
Advanced > File Locations 
(button near bottom). Then, 
select User templates and click 
the Modify… button. Change 
the location to: 
C:\Users\username\Documents
\Custom Office Templates 

  



Documenting Workflows 

8/25/2016   Page 10 of 23 
 

Getting Started with Documentation 

Using the MS Word Documentation Template 
The MS Word template, combined with the Training Guides tab on the Ribbon, is designed to streamline 
the process of creating documentation and help make documentation more uniform. This process relies 
on the use of Quick Parts to place tables into a document. The tables have the steps in the left column 
and an example, image or description in the right column that corresponds to the step. 

1. The template should be located 
in Documents > Custom Office 
Templates 

 

2. Create a document based on 
the template by double-clicking 
on the template file. 

 

3. Start a new page by selecting 
Insert > Page Break 

4. Add a pre-formatted table by 
selecting Insert > Quick Parts 
and Choose a Table that meet 
your needs. 
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5. When adding a second table, 
numbers will continue from the 
previous table. To reset the 
numbers, right-click on the 
first number in the list and 
select Restart at 1. 

6. Add a brief description under 
the heading for the table. 

7. Type the first step in the left 
column. 

8. Paste the corresponding image 
from SnagIt, in the right 
column and resize it. 

 

9. To increase the accessibility of 
the document, add an 
alternate description to the 
image by right-clicking the 
image and selecting Format 
Picture…  

a. In the Format Picture 
pane, Choose Layout 
and Properties 

b. Add a Description. 

10. To add additional rows, 
select Table Tools > Layout > 
Insert Below. 
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11. To automatically update the 
Table of Contents: 

a. Click in the Table of 
Contents 

b. Select Update Table… 
c. Choose Update entire 

table 
d. Click OK   

 Tip: 
Depending on your needs, consider adding tables/sections for 
Definitions, FAQs, Resources and/or Troubleshooting Common 
Problems. 
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Capturing Screens with SnagIt 
The instructions below assume that the keyboard shortcut for SnagIt (described in a previous section) 
has been put in place. 

1. Be sure the screen you are 
working with is visible and you 
are at the step in your process 
that you would like to capture. 

 

2. Press CTRL + ALT + C. There 
will be a delay of 3 seconds.  

 

3. Decide if you need a Menu or 
Cursor. 

Menu: The time delay allows you to capture an open menu.  
 
Cursor: If you want to include the cursor, place it in the 
appropriate location for the screen shot. If you do not want to 
include the cursor, move it out of the area you will capture. You 
can also delete the cursor later using the SnagIt editor. 

4. Section or Whole Window? 
a. Section - Drag a box 

around the portion of 
the screen that you 
want to capture. 

b. Window - Click on a 
window or dialog box to 
capture the entire 
dialog box. 
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5. The screen image will be 
copied to the clipboard. The 
image will also open in the 
SnagIt editor so that you can 
edit it if desired. 

 

6. Editing the image? No: If you do not need to edit the image (e.g. to add highlights), 
then you can close the SnagIt editor and paste the image into 
your documentation.   

 
Yes: Use SnagIt to edit the image as described in the next 

section. 

 Tip: 
Capture only the portion of the screen that is necessary to convey 
the meaning, while providing enough information to understand 
the context and so that the user can find the correct location. 
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Using the SnagIt Editor 
With the SnagIt settings that were put in place in a previous section, the editor will open automatically 
when a screen is captured. 

1. To add an arrow, click Arrow in 
the menu. To add a circle or 
rectangle, select Shape. 

2. In the Quick Styles pane on 
the right, select the style you 
would like.  

3. In the Tool Properties pane, 
adjust the settings as desired. 
For example, the thickness or 
color.  

4. Click and drag to add the 
shape to your document. 
 

Tip - Hold the Shift key 
while dragging a shape to 
make an arrow straight, or to 
create a perfect circle or a 
square. 

5. Other helpful edits.  
 
Note: These may appear under 
“More” in the toolbar. 

Blur 

Step 
(Automatically numbered)

Shapes  
(Circle or Rectangle) 
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6. To copy the image to the 
clipboard (to use in MS Word), 
select the Copy All button in 
the upper right of the SnagIt 
Editor. 

 
 

7. To use the image on the Wiki, 
select Share > File. Then, 
browse for a location to save 
the file. 

 Tip: 
Consider avoiding the color red for highlights. Red has been shown 
to have a negative impact on learning. 
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Recording the Screen Using Camtasia 

1. Open Camtasia from the Start 
Menu. 

2. Select Record the Screen 

 

3. Select the red record (rec) 
button. 
 
Settings used: 

a. Full Screen 
b. Webcam Off 
c. Audio On 

 

4. Tips while recording:  Talk through the recording process. 
 If you make a mistake, clap 3 times and keep going; you 

can remove the section later. 

5. Press F10 to stop the 
recording. Alternatively, select 
the Camtasia Recorder icon in 
the Taskbar and click Stop.  

OR
 

                      

  

6. Select Save and Edit, located 
in the lower right of the 
window. 
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Editing a Camtasia Screen Recording 

1. Press play to review the video. 

2. Select any errors by dragging 
the red and green handles to 
highlight the appropriate 
section. Remove the mistake 
by clicking the scissors icon or 
by pressing the CTRL + X on 
the keyboard. 

3. To adjust the audio, select the 

Audio button.  
4. Drag the green line up or down 

to increase or decrease 
volume. 

5. To add captions, select the 
More button and choose 
Captions.  
a. Position the playhead 

where the caption will be 
added. 

b. Click Add caption media. 
c. Type text into the text box.  
d. If necessary, drag the 

caption ends on the 
timeline to sync the caption 
with the audio. 

e. Repeat for all remaining 
captions. 
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6. Select File > Save project to 
save the project so that you 
can edit it later if necessary. 

7. Select File > Produce and 
Share… to create a video file. 

8. Select MP4 only (up to 1080p). 
Select Next. 

 

9. Name the video, choose a 
location and select Finish. 
 

 Tip: Once saved, upload 
to the Wiki or place in shared 
location, such as your 
department’s shared drive. 
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Using the Wiki Internal Documentation 

1. Open the Campus Wiki from 
the Portal and access your 
department’s Wiki space.  
 
Note: If your department does 
not have a Wiki space and 
would like to begin using the 
Wiki, please contact IT. 

2. Create a new blank page. 

3. Add a descriptive title, such as 
“How to Book a Room” 

4. Creating headings on the page. 
Headings might include: 

Introduction 
How to … 
How to … 
FAQs 
Additional Resources 

5. Insert a table with two 
columns. Place your cursor in 
the new table. 

 

6. Remove the Heading Row by 
selecting the Heading row 
button. 
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7. Add a Heading Column by 
selecting the Heading column 
button. 

8. Select the gear shaped Table 
settings icon. 

9. Check Insert a numbered 
column. 

10. Add a brief step description 
in column 2. 

11. In the third column, add the 
images or videos you created 
using SnagIt or Camtasia. 

12. To increase the accessibility of 
the document, add alternate 
text by selecting the image and 
choosing Properties. Add a title 
and alternate (Alt) text that 
describes the image. 
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13.  The final example might look 
like the following. 
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Resources 
Visit afd.calpoly.edu/training/ and select Toolkits > Documenting Workflows for more 
information and resources.  

Task Analysis  USDA NRCS Template  

Creating a Process 
Flowchart 

 Flowcharts in Microsoft Word 

 Flowcharts in Microsoft Excel 

Using MS Word  Using Quick Parts 

 Using Styles 

 Using Templates 

 Using Tables 

Using the Wiki  Wiki Central 

SnagIt  TechSmith Video Tutorials  

 Lynda: Learn Snagit for Mac 

Camtasia  TechSmith Video Tutorials 

 Lynda: 

o How to Create Instructional Videos in Camtasia 

o Learn Camtasia: Advanced Techniques 

o Screencasting Fundamentals 

o Camtasia Studio 8 Essential Training 

All TechSmith Tutorials https://www.techsmith.com/tutorial.html 

Creating Documentation Lynda: Creating Procedure Manuals and Documentation 

 

 


